nvidia-319-ck Arch Linux Packages

Home | Source Packages


Updated: 2014-02-06

Unfortunately, there is no place for this package to go.

  1. 32 isn’t compatible with xorg-server 1.15. The latest 319.76 IS compatible with xorg-server 1.15, but breaks other stuff on my machine (specifically vmware: https://bbs.archlinux.org/viewtopic.php?id=173111).

As such, there is no where else for this package to go. I am going to try NVIDIA’s recommended 304.119.

Ping me if you think otherwise.


To maintain the 319.XX versions of the nvidia proprietary drivers and utilities for current Arch Linux kernels.


Because the bleeding edge nvidia drivers have caused me more harm than good.


This repo contains Arch Linux source packages for the following packages:

‘319’ has been inserted into the package names to avoid conflicts with the main packages:

NOTE: Currently: we only create the nvidia kernel module for the linux-ck kernel. It should be easy to extend these packages for any kernel version. If you have questions, please ask.


You can find these packages on AUR. Use your favorite AUR helper (ie: yaourt), or download and build manaully.


These packages are what I (webmonarch) currently use on my Thinkpad w530. I hope they are useful to others.

Please fork and contribute!